Project: Abakus VCL
Question

State: All

User infoMartti Salerma
03.Jan.10 20:10
Subject:
Can not install Abakus with CBuilder2010

Description:
Hello,
I have exactly the same problem as ID-number 00104 has. Only one group of components can be seen. Have you already found the solution for this? I have Update4 of C++Builder2010 and Abakus VCL version 3.70 build0.
B.R. Martti Salerma

Files:
After_installation_as_Classic_view.GIF (14 kB)
After_installation_as_Classic_view_Analog_indicators.GIF (14 kB)
Error installing third package.GIF (11 kB)

User infoadmin
06.Jan.10 7:22
Comment:
did you try to
- first remove the Abakus Lib's manually from C++Builder, restart C++Builder and then manually add them again?

User infoMartti Salerma
08.Jan.10 18:13
Comment:
Hi, I have uninstalled all three packages. After restarting I can install the first package AbkDBStdBDS2010.bpl. I can thereafter install AbkLiBDS2010.bpl. But installing the third package AbkStdBDS2010.bpl, Iget the attached error. See the picture.
A second notice is, when I open no project,but begin a new form only. Thereafter I draw one Abdbaware component on the form. When I try to close the form, I get the message that Builder is looking for _GClass.h header file. But there exists only .hpp header files in folder???
A third notice is follow. When I have no open project, I can see in classic view all five component groups. Whe I change to default view, only AbDBAware can be seen. In both these modes AbDBAwares components icons are all the same odd picture.
All these notices, when I have in Builder and Project options "C:\Abakus\BDS2010" path in every possible place.
There must be some errors or overlappings in the packets.

b.R.

User infoadmin
09.Jan.10 7:54
Comment:
- The Error "third Package" is normal.... You installed the DB-Based package first and they are derived from components in the "third" package. So BCB will install it together with the DB-Aware package and you try to install it again.
- C++Builder requires ".h" or ".hpp" files, so if a h file is missing point to the hpp file.
Thanks for the other hint with "classic view", we will discuss this with embacadero

User infoGeoff Grime
12.Jan.10 21:37
Comment:
I see exactly the same thing as Martti.

(Configuration: Upgrading from Codegear C++Builder 2009 to Embarcadero C++Builder 2010. 2010 Upgrades 4 and 5 and Boost Lib installed. Abakus 3.70. Windows Vista Business SP1).

Eagerly awaiting a fix!!

User infoGeoff Grime
13.Jan.10 10:18
Comment:
Some further experience with BCB2010

1. Manually remove all three Abakus packages. Close BCB and re-open.
2. Close all open projects and files and manually reload the Abakus packages. All five Abakus tool group tabs appear correctly on the tab bar in classic view. AbDBAware appears after "Web services", the rest at the end after "Servers".
3. Load any project (either new or existing) and the last four disappear. Only AbDBAware is visible. The Tool Palette shows the same thing. All group tabs reappear when the project is closed.

User infoElkom
18.Jan.10 10:51
Comment:
I have the same problem from the beginning with BCB2010. I have BCB2009 so when I want to add componnents to 2010 I open the project in BCB2009, populate them, save then edit project file in the notepad and reopen it in BDB2010. This is definitely a fault of ABAKUS ! I have plenty of another third party componnets and __ALL__ other are good and properly seen!

User infoElkom
18.Jan.10 11:01
Comment:
In my "classic view" II don't have these groups also as in the "new view".
I have 2 computers XP and VISTA, all upgraded..

User infoGeoff Grime
03.Feb.10 18:01
Comment:
Any progress on this??

User infoRüdiger Britzen
16.Feb.10 20:46
Comment:
I got disappointed today as well, I have the same problem as the other users. When can a bugfix be expected?

User infoHans Lebahn
19.Feb.10 15:30
Comment:
I have the same problem!

User infoRüdiger Britzen
07.Mar.10 20:16
Comment:
When can I aspect an answer to my problem at least? I'm delaying a version release due to that issue!!

User infoGeoff Grime
16.Mar.10 12:04
Comment:
Some of you guys seem to be in Germany... Any chance of doing the community a favour and trying to phone Baecker to find out what's happening??

User infoRüdiger Britzen
16.Mar.10 20:16
Comment:
I will send a registered letter to Mr. Baecker tomorrow. Let's hope that I will at least get an answer!

User infoGeoff Grime
19.Mar.10 15:55
Comment:
Many thanks - much appreciated!

User infoHans Lebahn
30.Mar.10 17:41
Comment:
Please Mr. Baecker, any comment!

User infoRüdiger Britzen
17.Apr.10 22:09
Comment:
Mr. Baecker definitely received my letter, but even four weeks later I still have no answer from him... I'm considering contacting Digital River (they sold the Abakus VCL to me) and asking them about a refund.

User infoGeoff Grime
13.May.10 19:22
Comment:
I have developed a rather inelegant workround:

1. In BCB2009 with Abakus 3.70 installed, create a new VCL form. Call it something like AbkComponents.cpp

2. Put onto this form all the Abakus components that you are likely to use. Save it.

3. In CB2010 do a clean install of Abakus 3.70. Don't worry about not seeing all of the components in the menu.

4. Now, in every CB2010 project you just include AbkComponents.CPP and you can then copy and paste the components as you need them. Everything seems to compile properly.

This works for me; I hope it may be useful.

Thanks for trying to track down Baecker Rudiger. Looks like we won't be seeing any more new releases...

Best wishes,
Geoff.

Files:
AbkComponents.zip (6 kB)

User infoRüdiger Britzen
30.May.10 14:58
Comment:
Thanks Geoff,

your work-around does a perfect job!

I also contacted Digital River. They just answered that they are not responsible for technical issues and that by contacting sales@abaecker.biz I would get "optimal support". Well, lesson learned, I guess... :-(

User infoguohuang ji
14.Jun.12 14:00
Comment:
I have the same problem.BDS 2010(Update4/5,Boost Update), WINxp sp3,Abakus 3.70.
Only AbDBAware can be seen in Tool Palette .
Eagerly awaiting a fix!!

User infoguohuang ji
14.Jun.12 14:02
Comment:
I have the same problem.BDS 2010(Update4/5,Boost Update), WINxp sp3,Abakus VCL V3.90 Build 43.
Only AbDBAware can be seen in Tool Palette .
Eagerly awaiting a fix!!

User infoadmin
18.Jun.12 11:47
Comment:
Hi guohuang ji,
we send a email with a new created BDS2010 package to you email. Please try it and send a reply...

User infoadmin
18.Jun.12 18:27
Comment:
The Update 3.90b49, to fix this problem, is available on the Download page....


You are not logged-in
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot upload files in this forum